3.16. The “Main” Toolbar

The main toolbar provides quick access to frequently used items from the menu. This toolbar cannot be customized by the user, but it can be hidden using the View menu if the space on the screen is needed to show more packet data.

Items in the toolbar will be enabled or disabled (greyed out) similar to their corresponding menu items. For example, in the image below shows the main window toolbar after a file has been opened. Various file-related buttons are enabled, but the stop capture button is disabled because a capture is not in progress.

Figure 3.14. The “Main” toolbar

ws main toolbar

Table 3.14. Main toolbar items

Toolbar IconToolbar ItemMenu ItemDescription

x capture start

Start

Capture → Start

Starts capturing packets with the same options as the last capture or the default options if none were set (Section 4.3, “Start Capturing”).

x capture stop

Stop

Capture → Stop

Stops the currently running capture (Section 4.3, “Start Capturing”).

x capture restart

Restart

Capture → Restart

Restarts the current capture session.

x capture options

Options…​

Capture → Options…​

Opens the “Capture Options” dialog box. See Section 4.3, “Start Capturing” for details.

document open

Open…​

File → Open…​

Opens the file open dialog box, which allows you to load a capture file for viewing. It is discussed in more detail in Section 5.2.1, “The “Open Capture File” Dialog Box”.

x capture file save

Save As…​

File → Save As…​

Save the current capture file to whatever file you would like. See Section 5.3.1, “The “Save Capture File As” Dialog Box” for details. If you currently have a temporary capture file open the “Save” icon will be shown instead.

x capture file close

Close

File → Close

Closes the current capture. If you have not saved the capture, you will be asked to save it first.

x capture file reload

Reload

View → Reload

Reloads the current capture file.

edit find

Find Packet…​

Edit → Find Packet…​

Find a packet based on different criteria. See Section 6.8, “Finding Packets” for details.

go previous

Go Back

Go → Go Back

Jump back in the packet history. Hold down the Alt key (Option on macOS) to go back in the selection history.

go next

Go Forward

Go → Go Forward

Jump forward in the packet history. Hold down the Alt key (Option on macOS) to go forward in the selection history.

go jump

Go to Packet…​

Go → Go to Packet…​

Go to a specific packet.

go first

Go To First Packet

Go → First Packet

Jump to the first packet of the capture file.

go last

Go To Last Packet

Go → Last Packet

Jump to the last packet of the capture file.

x stay last

Auto Scroll in Live Capture

View → Auto Scroll in Live Capture

Auto scroll packet list while doing a live capture (or not).

x colorize packets

Colorize

View → Colorize Packet List

Colorize the packet list (or not).

zoom in

Zoom In

View → Zoom In

Zoom into the packet data (increase the font size).

zoom out

Zoom Out

View → Zoom Out

Zoom out of the packet data (decrease the font size).

zoom original

Normal Size

View → Normal Size

Set zoom level back to 100%.

x resize columns

Resize Columns

View → Resize Columns

Resize columns, so the content fits into them.

x reset layout 2

Reset Layout

View → Reset Layout

Reset layout to default size.